System requirements

The system requirements listed here are valid for the Net iD Enterprise 6.5.2 release. To get the system requirements for a specific older version of Net iD Enterprise, please see in the corresponding text file.

Operating Systems

Linux (32-bit and 64-bit versions):

  • Ubuntu 16.04 LTS

Microsoft Windows (32-bit and 64-bit versions):

  • Windows Server 2008 R2 Standard Edition

  • Windows Server 2008 R2 Enterprise Edition

  • Windows Server 2012 R2 Standard Edition

  • Windows Server 2012 R2 Datacenter Edition

  • Windows 7 Home Basic

  • Windows 7 Professional

  • Windows 7 Enterprise

  • Windows 7 Ultimate

  • Windows 8

  • Windows 8 Pro

  • Windows 8 Enterprise

  • Windows 8.1

  • Windows 8.1 Pro

  • Windows 8.1 Enterprise

  • Windows 10 Home

  • Windows 10 Pro

  • Windows 10 Enterprise

  • Windows 10 Enterprise 2015 LTSB

  • Windows 10 Education

OS X/macOS (32-bit and 64-bit versions):

  • macOS 10.12

  • OS X 10.11

Web browsers

  • Microsoft Edge (limited support)

  • Microsoft Internet Explorer 11 (only Desktop mode supported)

  • Mozilla Firefox 45.3 ESR (tests only performed on releases supported by Mozilla). See Known isssues and limitations.

  • Mozilla Firefox 49 (tests only performed on releases supported by Mozilla). No plugin support, see Known isssues and limitations.

  • Google Chrome v54 (tests only performed on latest release supported by Google). No plugin support, see Known isssues and limitations.

    • Safari 9 for OS X

  • Safari 10 for macOS

Regarding NPAPI plugin support in web browsers, se Known isssues and limitations.